Jump to content
ecarnell

Feb 15 - Kincardine Epic Fail

Recommended Posts

Well broke trail 35 km this am - absolutely gorgeous !!!!

Probably nicest ride had all year, from my own backyard ! (We are about 3,000km for the season thus far)

35 km in - another belt blew .... :(

 

spare I had left I wouldn’t have trusted very far so had to cut day very very short to my sons dis liking.

 

CE79DCBF-8148-4E2E-8C3C-05C9776E0F86.jpeg

51975FB7-8B38-4AB1-8129-70D1D2D2E9EF.jpeg

71296721-6370-49B2-9BD1-400F11B768D4.jpeg

9B3FA986-CCD1-448B-A6CE-07921548C49E.jpeg

796E3F88-8C94-4287-960F-A4F4F12DA958.jpeg

31E88C87-39B6-4255-BCB6-33E1595FFF1E.jpeg

0046D91B-C765-45C8-9357-6470BD10008A.jpeg

F5890A7A-4D66-4459-B0A9-DCF0D0B2CA09.jpeg

  • Like 5
Link to post
Share on other sites

Fabulous,  absolutely fabulous. Love the pictures.  

Link to post
Share on other sites

Great pics! That belt looks like my S-I-L's in Kap' 1 day. We gassed up, crossed back to the trail & headed west. I stopped west of town by the big Kap' sign. My buddy is behind me, but no sign of the other 2. I wait a couple minutes, no sound of approaching sleds. "The got across the highway" my buddy says. He is a bit on the 'bulky' side (especially when he layers u for sledding) so once he's ensconced on his sled, I think it's uncomfortable for to turn to look back. He does have a mirror on his left wrist.

 

Well we turn around & head back. Found bro' looking @ S-I-L's sled by the train station, changing the belt. She heard something under the hood. The cogs had started to fly off the inside. New belt & we were on our way. 

Link to post
Share on other sites

there is a spare belt on the 10th concession if u need to ride my friend, cheers

Link to post
Share on other sites
15 minutes ago, diesel04 said:

there is a spare belt on the 10th concession if u need to ride my friend, cheers

Thanks - but cleaned up clutches and ready for new belt tomorrow.

none in Canadian tire here in town - but port Elgin has 4 in stock (xtx5034).

 

son out playing on sled by himself now (with cell phone and tekvest).

think I may just relax and have a hot tub and beers with the wife!

 

hopefully we get some more snow and will be out later this week for sure!

 

  • Like 1
Link to post
Share on other sites
1 minute ago, ToSlow said:

picked a blown belt up on the trail through the farmers field  the other day,

I bring them home and hang up on the wall of shame !

  • Like 1
  • Haha 1
Link to post
Share on other sites
1 minute ago, ecarnell said:

I bring them home and hang up on the wall of shame !

i pick them up cause i don't want it getting into the equipment. 

Link to post
Share on other sites
1 minute ago, ToSlow said:

i pick them up cause i don't want it getting into the equipment. 

Same with beers cans we find on the trail... it’s too bad people don’t take them out with them or have garbage barrels near by.

This year seems to be worse than ever, with restaurants closed I suspect and people choosing to have a beer on side of trail instead.

  • Thanks 1
  • Sad 1
Link to post
Share on other sites
2 hours ago, ToSlow said:

picked a blown belt up on the trail through the farmers field  the other day,

Yea don't understand those folks who don't clean up after themselves. Had a buddy do it and I reamed him out. Like, REALLY?

 

  • Like 2
  • Thanks 2
Link to post
Share on other sites
2 hours ago, ecarnell said:

Thanks - but cleaned up clutches and ready for new belt tomorrow.

none in Canadian tire here in town - but port Elgin has 4 in stock (xtx5034).

 

son out playing on sled by himself now (with cell phone and tekvest).

think I may just relax and have a hot tub and beers with the wife!

 

hopefully we get some more snow and will be out later this week for sure!

 

Can i aso what make of belt your running on the 850?. 

Link to post
Share on other sites
18 minutes ago, Puggz said:

Yea don't understand those folks who don't clean up after themselves. Had a buddy do it and I reamed him out. Like, REALLY?

 

Atta boy

Link to post
Share on other sites
1 hour ago, Turbo Doo said:

Can i aso what make of belt your running on the 850?. 

original OEM “571” ran 4700km

 

next OEM “571” ran 1300km - did not do an easy break in....


last (today’s) belt, Dayco XTX5034 lasted approx 400km. Broken in easy, <100km/hr , no wide open throttle at all for first 80km.After that, “May” have been run hard....



ordered an RPX5034 last Friday, but don’t think it will arrive anytime soon, so will pick up an XTX5034 to keep me going.

 

 

Edited by ecarnell
Link to post
Share on other sites

Haaaa, from my experience with my '18 and my '19 MXZ X 850's, original factory belt, easy break in, always warmed it up before any big pulls, or high speeds. 5000kms each on both sleds. No issues. Always maintained proper belt adjustment also. Just a few things to consider from my own personal experience..

  • Like 1
Link to post
Share on other sites

Sooooo happy my 13 son is turning into a sled head with me. Considering this is his real first year on the trails, I’m soooo impressed on how he handles himself and the sleds (900 Ace and 850).

 

Warming up mom that new sleds may be coming next year (Polaris I think)....


 

At 12 he was trail riding a 250EXC and think that has matured him a lot to respect the power, attitude and all!

 

6601820A-1708-4C5F-86CE-C1E231CD4A46.thumb.png.3c7a324cb3b7f93d68fc3f3fe141e0c9.png

  • Like 2
Link to post
Share on other sites

I installed a new xtx5034 Saturday morning. Leaving my subdivision I could feel a vibration. Rode easy for 60kms and the first field I hit it let go. Not a happy camper. I need to pay the shipping and handling both ways on a defective belt for the get go. I not sure if I want to trust another one or not.

  • Thanks 1
Link to post
Share on other sites
1 hour ago, Turbo Doo said:

Haaaa, from my experience with my '18 and my '19 MXZ X 850's, original factory belt, easy break in, always warmed it up before any big pulls, or high speeds. 5000kms each on both sleds. No issues. Always maintained proper belt adjustment also. Just a few things to consider from my own personal experience..

Yep same. 19 850 backcountry w 146 skid. 4500 mi and original BRP belt. I rode this machine in Golden BC for several days last March. All good. I hear of others w belt failure on 850s but I’m not seeing it myself. ?

Link to post
Share on other sites
1 hour ago, J Feces said:

Yep same. 19 850 backcountry w 146 skid. 4500 mi and original BRP belt. I rode this machine in Golden BC for several days last March. All good. I hear of others w belt failure on 850s but I’m not seeing it myself. ?

Same here. Keeping up on belt adjustment,  and knowing that those 850s like to be warmed up before hammering on them, ( motor, belt),  and i did find the oem Doo belt was best, not the cheapest,  but good. Between my '18 and my '19, 5000kms on each, original belt on each. Never an issue. Even had a few other fellows ride the sleds also, never an issue. 

  • Like 1
Link to post
Share on other sites

Other than the cost, I dont think that the OEM belt for an 850 can be beat.   

Link to post
Share on other sites
32 minutes ago, scottyr said:

Other than the cost, I dont think that the OEM belt for an 850 can be beat.   

Agree, %100...:right_on:.. Same goes for the 900T...

Link to post
Share on other sites

Always used OEM, I may not ride as hard as a lot of you, but no issues. Yes I've had some start chunking, but nothing catastrophic. Yes there are other brands out there, but I've never really heard any glowing reports about the aftermarket belts. Considering the damage that can happen from a blown belt @ speed, why chance it over 10 bucks?

Link to post
Share on other sites
12 hours ago, scottyr said:

Other than the cost, I dont think that the OEM belt for an 850 can be beat.   

 

12 hours ago, Turbo Doo said:

Same here. Keeping up on belt adjustment,  and knowing that those 850s like to be warmed up before hammering on them, ( motor, belt),  and i did find the oem Doo belt was best, not the cheapest,  but good. Between my '18 and my '19, 5000kms on each, original belt on each. Never an issue. Even had a few other fellows ride the sleds also, never an issue. 

Totally agree with you both. My 18 Doo came with the 531 belt. Switched to the 571 as recommended by Doo.

OEM belts aren’t cheap but they’re all I’ll use or recommend.

  • Like 2
Link to post
Share on other sites
1 hour ago, manotickmike said:

Too bad a Yamaha belt won't fit...

Too bad a Yamaha engine won’t fit...

 

 

 

 

(sorry, bad joke)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...